GX not rendering or showing the HTML representation of the Validation Results

I followed the Quickstart | Great Expectations
This is the script I’m using:

"""Install GX
Run the following command in an empty base directory inside a Python virtual environment:
pip install great_expectations

# Run the following Python code to import the great_expectations module
import great_expectations as gx

# Run the following command to create a Data Context object
context = gx.get_context()

validator = context.sources.pandas_default.read_csv(

# Run the following commands to create two Expectations and save them to the Expectation Suite
    "passenger_count", min_value=1, max_value=6

# Run the following command to define a Checkpoint and examine the data to determine if it matches the defined Expectations
checkpoint = context.add_or_update_checkpoint(

# Run the following command to return the Validation Results
checkpoint_result = checkpoint.run()

# Run the following command to view an HTML representation of the Validation Results in the generated Data Docs

This is the output:

Jorge@DESKTOP-HFQR414 MINGW64 ~/git/great-expectations (main)
$ python app.py
Calculating Metrics: 100%|β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 6/6 [00:00<00:00, 857.44it/s]
Calculating Metrics: 100%|β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 8/8 [00:00<00:00, 515.22it/s]
Calculating Metrics: 100%|β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 15/15 [00:00<00:00, 526.09it/s]

But then it fails to render or open the results page:

I installed jupyter notebooks on my virtual environment (virtualenv) using this command:

python -m pip install jupyter

I tried again to no avail.

I’m using Python 3.12 on Windows 10 now, but I also tried with python 3.11 and failed just the same.
Do I need macOSX or is GX compatible with windows 10 and Python 3.12?

I don’t know what am I doing wrong.

It might be that you are running into the maximum file path length of windows

1 Like

As @Tim said, this might be due to the file path length limitations in Windows.
Check if this is the case. Go to the file location (AppData/Local/…), copy the HTML-file to your desktop (or wherever), and open it from there.
If it opens up just fine, great!
In that case, consider setting up a Filesystem Data Context, it should make the path shorter.
Run great_expectations init in your project folder to automatically do this.